[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Missing dependency for a non-existing package



On Sunday 24 February 2008 08:27:42 pm Lamont Peterson wrote:
> All,
>
> I've attached the output from my simple "yum update" command.  This has
> been pestering me for over a week now.
>
> It seems that device-mapper-devel >= 1.02.02-3 is needed by package
> e2fsprogs-devel, but there is no such package as device-mapper-devel i nthe
> repos.
>
> I need e2fsprogs-devel at the end of a chain of things from kdevelop ->
> kdelibs-devel -> krb5-devel -> e2fsprogs-devel (I've also asked why
> e2fsprogs-devel is providing libs, but I haven't had a response from the
> maintainer, yet).
>
> I've tried to --exclude e2fsprogs-devel, e2fsprogs etc, but it wont exclude
> it, they keep getting pulled back in.  Besides, this seem to me to be an
> obviously broken dep in the repo, anyway.
>
> Suggestions?

After some painstaking manual labor updating packages just a small handful at 
a time, I realized that I had the 'yum-skip-broken' plugin installed, so a 
simple 'yum --skip-droken update' command got all the rest of the available 
updates that would work installed.  That left me with just one update that cn 
not be installed: e2fsprogs, which forces me to update e2fsprogs-devel at the 
same time.  It's the e2fsprogs-devel package that is depending on 
device-mapper-devel, which doesn't seem to exist in the repos (at least, yum 
can't find it).
-- 
Lamont Peterson <lamont lamontpeterson org
[ http://lamontpeterson.org/ ]
GPG Key fingerprint: C51E DD83 B03F D147 A974  939C 5D13 289C 17F1 FFBE

Attachment: signature.asc
Description: This is a digitally signed message part.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]