[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

KDE4 dangling-symlink and symlink-should-be-relative



Dear all,

Packaging rkward for KDE4 I am facing a small problem.

It packages fine, but running rpmlint on the rpm made I get the following errors: rkward.x86_64: W: dangling-symlink /usr/share/doc/HTML/en/rkward/common /usr/share/doc/HTML/en/common rkward.x86_64: W: symlink-should-be-relative /usr/share/doc/HTML/en/rkward/common /usr/share/doc/HTML/en/common

I remember having these error on KDE3, solving it by adding this to the spec:
## File lists
# locale's
%find_lang %{name} || touch %{name}.lang
# HTML (1.0)
HTML_DIR=$(kde-config --expandvars --install html)
if [ -d $RPM_BUILD_ROOT$HTML_DIR ]; then
for lang_dir in $RPM_BUILD_ROOT$HTML_DIR/* ; do
  if [ -d $lang_dir ]; then
    lang=$(basename $lang_dir)
    echo "%lang($lang) $HTML_DIR/$lang/*" >> %{name}.lang
   # replace absolute symlinks with relative ones
    pushd $lang_dir
      for i in *; do
[ -d $i -a -L $i/common ] && rm -f $i/common && ln -sf ../common $i/common
      done
    popd
  fi
done
fi

So I tried to do that for my package, but I ended with the following error:
 kde-config: command not found

I remember that these rpmlint error were quite common on KDE3, how should I handle them on KDE4 ??

My BR are for now:
BuildRequires:  R-devel desktop-file-utils gettext PyQt-devel
BuildRequires:  kdelibs-devel cmake pcre-devel
BuildRequires:  qt-devel giflib-devel

Thanks in advance for you help :)

Regards,
Pierre


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]