[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20080211 changes



Nicolas Mailhot wrote:
Le Mar 26 février 2008 17:27, Xavier Bachelot a écrit :

Here's another try at xerces-c27 :

http://washington.kelkoo.net/fedora/SPECS/xerces-c27.spec
http://washington.kelkoo.net/fedora/SRPMS/xerces-c27-2.7.0-2.fc8.src.rpm

rpmlint output (most of the errors are also in the original xerces-c
package) :
xerces-c27.i386: E: non-standard-executable-perm
/usr/lib/libxerces-depdom.so.27.0 0775

Replace your %defattr(-,root,root,-) with more specific permissions ;
trusting every single upstream to get this right is hopeless and
unless you audit the permissions after every update explicit defattr
is a good safety belt.

xerces-c27-doc.i386: W: file-not-utf8
/usr/share/doc/xerces-c27-doc-2.7.0/doc/migration.xml

Convert it at build time to proper UTF-8

This 2 warnings (and probably the others) will be easily fixed and need to be fixed in the original xerces-c package too. Thanks anyway :-)
My question was more about the general shape of the 'compat' package.

Regards,
Xavier





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]