[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Policy proposal for compatibility packages



On Thu, Jan 03, 2008 at 09:35:37PM +0100, Linus Walleij wrote:
> On Thu, 3 Jan 2008, Patrice Dumas wrote:
>
>>> And then s/he knows that in Fedora, we love to discard old
>>> API:s.
>>
>> I hope it is untrue. I hope everybody here dislikes breaking API and
>> ABIs and try to push the upstreams to be responsible with API/ABI.
>
> Of course upstream is responsible, man, calm down.

No, I am saying that we should push upstream to have backward compatible
API, as long as it doesn't deter innovation.

> It seems you read me like I thought breaking API/ABI was a goal in itself, 
> that's not what I meant.

You also seem to say that having backward compatible API is not a goal
in itself. In my opinion it is, and it is among the responsibility of
distribution packagers to communicate with upstream to avoid
incompatible API change, because upstream has less incentive than us to
avoid API change. Of course users are the category with most need for
API stability, but their only way to communicate thir concerns is to
leave fedora and try a distro with less issues with broken deps in 
updates linked with soname bumps -- even when fedora packagers are not
the culprits, and upstream is.

--
Pat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]