[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: New tcl-8.5 and 8Kingdoms



I had also look at it and ask upstream about help.

Hans de Goede wrote:
Michael Thomas wrote:
Hans de Goede wrote:
Hi all,

I just tried building 8Kingdoms with the new tcl in rawhide, it builds
fine, but it does not work.

Any of the actions (moving a unit for example) which normally invoke a
tcl script underneath now no longer work.

I'm quite good in fixing C bugs but this problem lies either in the
interfacing with tcl or in the tcl code itself and I'm helpless there.
So I hope that someone can try running 8Kingdoms with tcl 8.5, and write
a fix.

Note I've also send a request upstream asking for help, I'll report back
here as soon as I get response.

If I don't have it fixed by F-9 then I will have to remove 8Kingdoms
from Fedora's repositories (better then shipping a broken version).

Did you have to make any changes to 8Kingdoms to get it to build with
Tcl 8.5?  If so please pass along any patches.  I'll try building and
running it myself to see if I can track down the problem.


Nope,

No changes, I also did a diff between the buildlogs, no new compiler warnings or anything like that.

I did build it with gcc-4.3, as I was working on it not building with gcc-4.3 too.

I've just committed my latest 8Kingdoms work to cvs, so you can get it from there, including a patch for the crash you reported (tested using tcl 8.4).

Thanks,

Hans



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]