[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Mass rebuild status with gcc-4.3.0-0.4 of rawhide-20071220



On Thu, 2008-01-03 at 07:02 -0500, Jakub Jelinek wrote:
> Hi!
> 
> I've rebuilt 5118 rawhide-20071220 src.rpms on x86_64 in mock buildroots which
> contained rawhide-20071220 except {gcc,lib}*-4.1.2-36.*.rpm, with additional
> gcc-4.3.0-0.4 (available from koji, dist-f9-gcc43 component),
> compat-libgfortran-41 (available from
> http://people.redhat.com/jakub/gcc/compat-libgfortran-41-4.1.2-36.src.rpm )
> and later on also with gettext subpackages just rebuilt with gcc-4.3.0-0.4.
> 
> Out of those 5118 src.rpms 1054 were failed builds.  For those that failed
> to build, I have retried with stock rawhide-20071220 mock buildroots (i.e.
> gcc-4.1.2-36).  547 failed builds failed even with 4.1.2-36 (this count
> includes even ExclusiveArched rpms etc.), logs for those are at
> http://sunsite.mff.cuni.cz/rawhide20071220-gcc43/fails-even-with-41/
> and generally don't interest me, as this is not a regression introduced by
> 4.3.0-0.4.
> 
> The remaining 507 failures only fail with gcc-4.3.0-0.4 and not with
> gcc-4.1.2-36, though most of them are just C++ being stricter, something
> that ought to be fixed in the packages.
> 
> I've tried to quickly grep through the failed logs and categorize them:

[snip]

> header-dep/openvrml-0.17.0-2.fc9.log

I see two problems here. First:

        libopenvrml-gl/openvrml/gl/viewer.cpp:1984: error: '<anonymous>' has incomplete type
        libopenvrml-gl/openvrml/gl/viewer.cpp:1984: error: invalid use of 'GLvoid'

This one should be fixed by 0.17.1-1, which I've just pushed to testing.

Second:

        In file included from /usr/include/boost/spirit/attribute/closure.hpp:24,
                         from /usr/include/boost/spirit/attribute.hpp:36,
                         from /usr/include/boost/spirit.hpp:70,
                         from ../src/libopenvrml/private.h:26,
                         from libopenvrml/openvrml/viewer.cpp:32:
        /usr/include/boost/spirit/phoenix/operators.hpp:355: error: 'INT_MAX' was not declared in this scope

This one is a problem with boost.

-- 
Braden McDaniel                           e-mail: <braden endoframe com>
<http://endoframe.com>                    Jabber: <braden jabber org>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]