[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Pulse Audio 0.9.8 - upgrade?



On Thu, 10.01.08 22:07, Warren Togami (wtogami redhat com) wrote:

> Does upgrading from 0.9.7 to 0.9.8 break library ABI with applications 
> already linked against any pulseaudio library?  If not, we should really 
> explore the possibility of upgrading to a newer pulseaudio version in 
> Fedora 8.

ABI is stable in all 0.9.x versions.

> Later when the test users agree that the pulseaudio package in your test 
> repository is seemingly good, it can be pushed to F8's updates-testing 
> repository where many thousands of other users who opt-in to that optional 
> channel will be exposed to it.  It can be tested there for a while before 
> pushing to the public in the stable updates channel.  This multi-layered 
> approach to testing should ensure that the update is of higher quality than 
> the current F8 pulseaudio.
>
> Pulseaudio made many applications that used to be stable suddenly 
> unreliable.  Apps like pidgin, mplayer, xine, Adobe Flash Player and
> many 

Uh, don't get me started on Flash.

> more now have weird pulseaudio related crash issues.  There is a desire to 
> pull in newer pulseaudio versions if bugs are fixed to make it more stable.
>
> Please let us explore the feasibility of upgrading it in F8?

I will put a copy of 0.9.8 in updates-testing. 

Lennart

-- 
Lennart Poettering                        Red Hat, Inc.
lennart [at] poettering [dot] net         ICQ# 11060553
http://0pointer.net/lennart/           GnuPG 0x1A015CC4


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]