[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Rebuilds for new Perl?



On Sunday 20 January 2008, Tom "spot" Callaway wrote:
> On Sun, 2008-01-20 at 21:50 +0200, Ville Skyttä wrote:
> > On Sunday 20 January 2008, Tom "spot" Callaway wrote:
> > > Because everything that depends on perl needs to be rebuilt,
> >
> > Hmm, that sounds odd to me, could you confirm this?
> >
> > I'd assume that all packages that ship files in /usr/lib*/perl5 or things
> > linked with libperl.so would require a rebuild, but that'd be about it.
>
> perl packages have:
> Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo
> $version))
>
> (As an aside, I thought this might be autogenerated, but it isn't.)
>
> This means that they all depend on perl(:MODULE_COMPAT_5.8.8), thus,
> need to be rebuilt against perl 5.10.0.

Sure, but that "Requires: perl(:MODULE_COMPAT_5.8.8)" should only be in 
packages that install files to /usr/lib*/perl5/[...] .  If other packages 
have it, the likelihood of a packaging bug is pretty high I think, but 
nevertheless they do need a rebuild, understood.

But surely not *everything* in the distro that depends on perl needs a 
rebuild?  Eg. stuff that just needs /usr/bin/perl or installs some *.pm to 
their application specific paths and nothing to perl's paths (and nothing 
that links with libperl.so)?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]