[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Rebuilds for new Perl?



On Sun, 2008-01-20 at 22:20 +0200, Ville Skyttä wrote:

> Sure, but that "Requires: perl(:MODULE_COMPAT_5.8.8)" should only be in 
> packages that install files to /usr/lib*/perl5/[...] .  If other packages 
> have it, the likelihood of a packaging bug is pretty high I think, but 
> nevertheless they do need a rebuild, understood.
> 
> But surely not *everything* in the distro that depends on perl needs a 
> rebuild?  Eg. stuff that just needs /usr/bin/perl or installs some *.pm to 
> their application specific paths and nothing to perl's paths (and nothing 
> that links with libperl.so)?

Everything that has that Requires needs a rebuild, but that Requires may
not be needed in all the packages where it is present.

I'm not sorting that out right now, just doing a series of rebuilds. :)

~spot


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]