[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F8 to rawhide upgrade - yum python mismatch - repeatable



David Timms wrote:
darrell pfeifer wrote:
In current rawhide, yum (or yum utils) has a dependency on a particular
python module, but it the python chunk isn't pulled in by the yum upgrade.
After upgrading yum, yum won't run any more.

I had a minimal F8 vmware VM, and yesterday intended to do a yum upgrade to get to rawhide. I installed fedora-release which gets me the fedora-development.repo and fedora-release files.
I then tried a yum check-update, and saw the heap of updates.
Next I yum update rpm* yum*, which seemed OK.
After that yum didn't work anymore.
rpm was still working, so I upgraded groups of packages at a time.

I managed to kill it in this process by running out of disk space while upgrading glibc, and others ;( and now she doesn't run commands or boot, I'm going to try again to get the error message.

DaveT.

Ok that definitely sounds like an issue that needs looked at deeper. Upgrading rpm and yum first off should not break yum right away! Doing just yum works fine for an updated machine as I showed, but maybe the base versions of rpm and yum for F8 have issues with that update.

--
Andrew Farris <lordmorgul gmail com> <ajfarris gmail com>
 gpg 0xC99B1DF3 fingerprint CDEC 6FAD BA27 40DF 707E A2E0 F0F6 E622 C99B 1DF3
No one now has, and no one will ever again get, the big picture. - Daniel Geer
----                                                                       ----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]