[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

revisor - is this a bug or is it me?



I'm not sure if this is a bug so that is why I'm writing here first.

I would like to respin Fedora 8 Live CD, and I read documentation from
pungi and revisor and it seams straightforward. But this is my fist
time using it so I can't deny that the issue could be between the
keyboard and the chair :)

So these are my steps:

1. Put selinux to permissive mode

2. Launch revisor

3. after being prompted for root password I type it in

4. on first screen "show advanced options" is grayed out so I click
only thing I can - "Get Started"

5. On second screen [1] I choose "DVD Set"  and "Optical Live Media"
(I choose DVD despite Fedora 8 Live is a CD and not a DVD because on
second screen it showed it needs 777MB of data and AFAIK CDs can't
store more than 700MB) and clicked "Forward"

6. on third screen [2] I left "Revisor Configuration" by default to
"/etc/revisor/revisor.conf"
for "Configuration Section to Use" I choose "f8-i386" and clicked on
apply (is apply necessary? repositories should change automatically as
you choose configuration you want), I left destination directory to
it's default "/srv/revisor/f8-i386" and I clicked forward

7. on fourth screen [3] for "Kickstart Configuration File" I choose
"/usr/share/fedora-release/livecd-fedora-desktop.ks" and I checked
these options:
use repositories configured in the kickstart file
use package manifest from kickstart data
include kickstart file on installation media
set installer to boot with kickstart by default

My intention was to recreate respin that was identical to official
one, only with never packages, that is why I didn't choose any
customization options.

then I click forward and then I came across this bug [4] and you can
see the screenshot [5]

8. after clicking all those warnings for missing files I came to fifth
screen and clicked forward

9. and again warnings about missing files [6], and after clicking the
last one respining statred.

I saw lots of messages in revisor window "stat: cannot stat `chroot':
No such file or directory" and also posted a bug [7] regarding that in
bugzilla.

10. I got another error [8] because of some conflicts :( This one I
didn't put on bugzilla.

Can you please check if I am doing something wrong or are all these
legitimate bugs and revisor is broken temporarily?

Cheers,
Valent.

[1] http://www.uploadgeek.com/uploads456/0/Screenshot-Revisor-1.png -
second screen
[2] http://www.uploadgeek.com/uploads456/0/Screenshot-Revisor-livecd-1.png
- third screen
[3] http://www.uploadgeek.com/uploads456/0/Screenshot-Revisor-livecd-2.png
- fourth screen
[4] https://bugzilla.redhat.com/show_bug.cgi?id=429681 - revisor
missing files bug
[5] https://bugzilla.redhat.com/attachment.cgi?id=292502 - revisor
missing files #1
[6] https://bugzilla.redhat.com/attachment.cgi?id=292503 - revisor
missing files #2
[7] https://bugzilla.redhat.com/show_bug.cgi?id=429689 - cp: cannot
stat 'chroot'
[8] http://www.uploadgeek.com/uploads456/0/Screenshot-Revisor-error.png

-- 
http://kernelreloaded.blog385.com/
linux, blog, anime, spirituality, windsurf, wireless
registered as user #367004 with the Linux Counter, http://counter.li.org.
ICQ: 2125241, Skype: valent.turkovic


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]