[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F8 to rawhide upgrade - yum python mismatch - repeatable



Andrew Farris wrote:
David Timms wrote:
/usr/lib/python2.5/site-packages/_sqlitecache.so: undefined symbol: g_assertion_message_expr

...

Yes, python-urlgrabber should have been upgraded to fc9
I don't have the .fc9 one at the moment, however:
rpm -q --requires yum
/usr/bin/python
config(yum) = 3.2.8-2.fc9
python >= 2.4
python(abi) = 2.5
python-iniparse
python-sqlite
rpm >= 0:4.4.2
rpm-python
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
urlgrabber
yum-metadata-parser >= 1.1.0

* note no version of urlgrabber mentioned so any should do.

[davidt localhost ~]$ rpm -q --whatprovides urlgrabber
python-urlgrabber-3.0.0-3.fc8
* I have one installed.

as should the other python rpms.
python and python-libs are part of python itself. The others are independent developments, with their own versions.

It looks like there could be a requires missing to get those to move up to the fc9 version.
I might be getting this wrong; the requires is trying to guarantee the packages work with each other, by requiring stuff provided by other packages, and specifying versions, if a specific version is required. I don't think it is necessary to have all packages with .fc9. for things to work normally. In any case, a later yum update would notice the things that have updates, and update them.

Did you see anything about that when updating python?
no.

Do you have the yumskipbroken plugin when doing that upgrade?
no. yum-skip-broken is not installed.

DaveT.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]