[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F8 to rawhide upgrade - yum python mismatch - repeatable



seth vidal wrote:
On Wed, 2008-01-23 at 00:24 +1100, David Timms wrote:
$ rpm -qa yum\* rpm\* python\* sql\*|sort
yum-3.2.8-2.fc8
* this was .fc8. because I tried downgrading to see if yum would work again. current: yum-3.2.8-2.fc9

yum-metadata-parser-1.1.2-4.fc9
[davidt localhost ~]$ yum --help
...
/usr/lib/python2.5/site-packages/_sqlitecache.so: undefined symbol: g_assertion_message_expr

remove yum-metadata-parser via rpm -e, please
# rpm -e yum-metadata-parser
error: Failed dependencies:
yum-metadata-parser >= 1.1.0 is needed by (installed) yum-3.2.8-2.fc9.noarch
# rpm -e yum-metadata-parser --nodeps

and then try running yum.
# yum update
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   No module named sqlitecachec

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.5.1 (r251:54863, Jan 17 2008, 11:02:11)
[GCC 4.1.2 20071124 (Red Hat 4.1.2-36)]

* the module missing changed, but no go.

if yum works then yum install yum-metadata-parser and tell me if it
still balks.
else:
  rpm -Uvh yum-metadata-parser-1.1.2-4.fc9.i386.rpm
Preparing... ########################################### [100%] 1:yum-metadata-parser ########################################### [100%]
[root localhost packages]# yum
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

/usr/lib/python2.5/site-packages/_sqlitecache.so: undefined symbol: g_assertion_message_expr


* back to original message

Will install the newer -metadata-parser when it becomes visible...

DaveT.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]