[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Headsup: new API and ABI changing goffice update headed towards rawhide



Hi All,

I've been working on updating gnumeric to the 1.8.x tree, this needs the latest stable 0.6 series of goffice, therefor I'm also updating goffice from 0.2 to 0.6, which means a change in soname, and in API.

The only other user is abiword, a patch for abiword for the 0.5 devel series of goffice, which lead to the 0.6 release is available here:
http://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/SOURCES/abiword-goffice05.patch?rev=1.1

It should be trivial to adjust this patch to make abiword 's charting plugin work with goffice-0.6 (search replace 0.5 with 0.6).

---

Another problem is that we also have the special goffice04 package as some packages needed goffice-0.4, while others where still using 0.2 . For now we can keep this package until the 0.4 users move over to 0.6, but there is a conflict between goffice04 and the new goffice-devel . The problem are a bunch of files under /usr/share/gtk-doc/html/goffice. Notice that this are API reference doc, so in the goffice04 case the are wrongly in the main package and they should be moved to the -devel package. This would make the conflict less severe as it then is a conflict between devel files, but still a conflict. Suggestion, move those files to the -devel package of goffice04 and put them under /usr/share/gtk-doc/html/goffice04 to avoid the conflict.

Thanks & Regards,

hans


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]