[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Libsoup troubles in rawhide (compat-libsoup22 needed)



>>>>> "DB" == Dmitry Butskoy  writes:

DB> The new "libsoup" library in rawhide, version 2.3.0, introduces a
DB> lot of API incompatibility, comparing with the previous 2.2.x
DB> versions. There are even some design changes, hence it seems
DB> impossible for package maintainers to do "just a monkey job" of
DB> renaming functions etc. In my case of "libtranslate" (which
DB> depends on libsoup), it requires a deep upstream intervention
DB> (which, surely, was not in upstream's todo list...)

DB> It could be fine to have "libsoup22" or "compat-libsoup-2.2"
DB> package in rawhide.
 
Not to mention the fact that this major soname ABI/API bump was not
announced in advance!  The maintainer should have posted at least a
day or so in advance to fedora-devel-announce-list to warn packagers
in advance of the major change (which would have allowed discussion of
the possibility of the necessity of introducing compat-libsoup type
package).

Here's the full list of packages broken either directly or indirectly
by this change:

(from http://koji.fedoraproject.org/mash/rawhide-20080129/logs/depcheck)

bmpx-0.40.13-7.fc9.i386 requires libsoup-2.2.so.8
1:bug-buddy-2.20.1-1.fc9.i386 requires libsoup-2.2.so.8
buoh-0.8.2-2.fc7.i386 requires libsoup-2.2.so.8
drivel-2.1.1-0.3.20071130svn.fc9.i386 requires libsoup-2.2.so.8
evolution-brutus-1.1.28.7-2.fc8.i386 requires libcamel-1.2.so.10
evolution-webcal-2.12.0-1.fc8.i386 requires libsoup-2.2.so.8
hardinfo-0.4.2.3-1.fc9.i386 requires libsoup-2.2.so.8
libepc-0.3.3-1.fc9.i386 requires libsoup-2.2.so.8
libsyncml-0.4.5-1.fc9.i386 requires libsoup-2.2.so.8
libtranslate-0.99-12.fc9.i386 requires libsoup-2.2.so.8
1:logjam-4.5.3-9.fc8.3.i386 requires libsoup-2.2.so.8
mail-notification-evolution-plugin-5.0-0.2.rc1.fc9.i386 requires
libcamel-provider-1.2.so.10
mail-notification-evolution-plugin-5.0-0.2.rc1.fc9.i386 requires
libcamel-1.2.so.10
planner-eds-0.14.2-10.fc9.i386 requires libcamel-provider-1.2.so.10
planner-eds-0.14.2-10.fc9.i386 requires libcamel-1.2.so.10
rhythmbox-0.11.4-4.fc9.i386 requires libsoup-2.2.so.8
seahorse-2.21.4-3.fc9.i386 requires libsoup-2.2.so.8
swfdec-gtk-0.5.5-2.fc9.i386 requires libsoup-2.2.so.8
totem-pl-parser-2.21.91-1.fc9.i386 requires libcamel-1.2.so.10
totem-publish-2.21.90-2.fc9.i386 requires libsoup-2.2.so.8
twitux-0.60-2.fc9.i386 requires libsoup-2.2.so.8

Alex


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]