[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Bug in mock: Error with building kmod packages in RHEL



1) $ mock -r redhat-5-i386 --target=i686
ipw3945-kmod-1.2.0-4.8.el5.src.rpm 

2) $ rpm -qp
-R /var/lib/mock/redhat-5-i386/result/kmod-ipw3945-1.2.0-4.8.el5.i686.rpm 
rpmlib(VersionedDependencies) <= 3.0.3-1
/sbin/depmod  
/sbin/depmod  
/bin/sh  
/bin/sh  
/bin/sh  
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

[[[Requires are INCORRECT for RHEL!]]]

3) Patching backend.py: backend.py.diff
--- backend.py.orig     2008-03-17 06:32:35.000000000 +0200
+++ backend.py  2008-07-01 15:47:16.000000000 +0300
@@ -291,6 +291,7 @@
         os.symlink("/proc/self/fd/0", self.makeChrootPath("dev/stdin"))
         os.symlink("/proc/self/fd/1",
self.makeChrootPath("dev/stdout"))
         os.symlink("/proc/self/fd/2",
self.makeChrootPath("dev/stderr"))
+        os.symlink("/proc/self/fd", self.makeChrootPath("/dev/fd"))
         os.umask(prevMask)

         # mount/umount


4) $ mock -r redhat-5-i386 --target=i686
ipw3945-kmod-1.2.0-4.8.el5.src.rpm 

5) $ rpm -qp
-R /var/lib/mock/redhat-5-i386/result/kmod-ipw3945-1.2.0-4.8.el5.i686.rpm 
rpmlib(VersionedDependencies) <= 3.0.3-1
/sbin/depmod  
/sbin/depmod  
/bin/sh  
/bin/sh  
/bin/sh  
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
kernel(rhel5_net_ieee80211_ga) =
266557407e6293b3d4447d740257a79c67cb9d4b
kernel(rhel5_mm_ga) = 09f63dfab81bba7e01a2bf693f5ce125db466051
kernel(rhel5_drivers_pci_ga) = 33d9e0612417f727a0d8311c229fe8a80c65bb65
kernel(rhel5_net_core_ga) = 5aae342a66dcbcc14a7c1c001624f73a13620809
kernel(rhel5_drivers_base_ga) = 2490efa8790e7d4b3c7ae4536866c48f1334a356
kernel(rhel5_kernel_ga) = 2cd142708e2d573b2de522df5df87aaeb7c1d298
kernel(rhel5_kernel_module_ga) =
1b051ce57d6b18fdf071786f6f7296d3d0ab28f9
kernel(rhel5_lib_ga) = 088a6b77cde4f82c65b0d7f34802cfa41d209328
kernel(rhel5_fs_sysfs_ga) = bb43e88ba2b9ebed086513342d9a5a18ed9355a7
kernel(rhel5_kernel_irq_ga) = 828c3f468e7a640d409d2bf24b4676e457406917
kernel(rhel5_arch_i386_mm_ga) = 0164a9bd3f1d0935cd3dcb734785179f25c1a064
kernel(rhel5_arch_i386_kernel_ga) =
d1c30e0a553e9225eebd1b866e0d3ed7a6154147
kernel(rhel5_net_sched_ga) = 85d96cb2f432b540922c05edf889854d63884830
kernel(rhel5_drivers_char_ga) = 9825f97c6773e4d766359d55afa360b0c31cd1a6
kernel(rhel5_vmlinux_ga) = 2bf444396ff7060828059d7a5379435140aee48a

[[[Requires are CORRECT for RHEL!]]]



Please, add patch to mock to fix the error with building kmod packages
in RHEL



Additinal information:
--------------------------------------------------------------------------------------
RHBZ#453583

--------------------------------------------------------------------------------------
ipw3945-kmod-1.2.0-4.8.el5.src.rpm can be found in
rhel-5.2-server-supplementary-i386-disc1.iso

--------------------------------------------------------------------------------------
$ rpm -q mock
mock-0.9.7-1.el5 (from EPEL)

--------------------------------------------------------------------------------------
$ cat /etc/issue
Red Hat Enterprise Linux Server release 5.2 (Tikanga)

--------------------------------------------------------------------------------------
$ cat /etc/mock/redhat-5-i386.cfg
config_opts['root'] = 'redhat-5-i386'
config_opts['target_arch'] = 'i386'
config_opts['chroot_setup_cmd'] = 'install buildsys-build'
config_opts['macros']['%dist'] = ".el5"
config_opts['macros']['%el5'] = "2"

config_opts['yum.conf'] = """
[main]
cachedir=/var/cache/yum
debuglevel=1
reposdir=/dev/null
logfile=/var/log/yum.log
retries=20
obsoletes=1
gpgcheck=0
assumeyes=1
metadata_expire=1

# repos

[rhel]
name=rhel
baseurl=file:///var/data/linux/redhat/5.2/i386


[rhel-updates]
name=rhel-updates
baseurl=file:///var/data/linux/redhat/5.2/updates/i386


[groups]
name=groups
baseurl=file:///var/data/linux/redhat/5.2/updates/groups/i386


"""


--------------------------------------------------------------------------------------
$ cat /etc/mock/site-defaults.cfg
config_opts['plugin_conf']['ccache_enable'] = False



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]