[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F-9 Updates : gnome-sharp and gtk-sharp2



>>>>> "XL" == Xavier Lamien  writes:

[...]

>> http://koji.fedoraproject.org/koji/taskinfo?taskID=696144

>> Since the version of gnome-sharp in rawhide is already broken, can
>> you just do a standard (non-scratch) build of gnome-sharp so it
>> available for other packages to build against?

XL> Done

Xavier, thanks.  That fixes the .pc file issue, but f-spot still won't
compile against gnome-sharp-2.20, because for some reason it doesn't
provide gtkhtml anymore:

checking for GTKHTML_SHARP... 
configure: error: Package requirements (gtkhtml-sharp-3.14 >= 2.19.90)
were not met: No package 'gtkhtml-sharp-3.14' found

http://koji.fedoraproject.org/koji/getfile?taskID=697279&name=build.log

Looking at the provides for the new package.  It appears that gtkhtml
is now longer provided.

gnome-sharp = 2.20.0-2.fc10
libgnomesharpglue-2.so
mono(art-sharp) = 2.20.0.0
mono(gconf-sharp) = 2.20.0.0
mono(gconf-sharp-peditors) = 2.20.0.0
mono(gconfsharp-schemagen) = 0.0.0.0
mono(gnome-sharp) = 2.20.0.0
mono(gnome-vfs-sharp) = 2.20.0.0
mono(policy.2.16.art-sharp) = 0.0.0.0
mono(policy.2.16.gconf-sharp) = 0.0.0.0
mono(policy.2.16.gconf-sharp-peditors) = 0.0.0.0
mono(policy.2.16.gnome-sharp) = 0.0.0.0
mono(policy.2.16.gnome-vfs-sharp) = 0.0.0.0
mono(policy.2.4.art-sharp) = 0.0.0.0
mono(policy.2.4.gconf-sharp) = 0.0.0.0
mono(policy.2.4.gconf-sharp-peditors) = 0.0.0.0
mono(policy.2.4.gnome-sharp) = 0.0.0.0
mono(policy.2.4.gnome-vfs-sharp) = 0.0.0.0
mono(policy.2.6.art-sharp) = 0.0.0.0
mono(policy.2.6.gconf-sharp) = 0.0.0.0
mono(policy.2.6.gconf-sharp-peditors) = 0.0.0.0
mono(policy.2.6.gnome-sharp) = 0.0.0.0
mono(policy.2.6.gnome-vfs-sharp) = 0.0.0.0
mono(policy.2.8.art-sharp) = 0.0.0.0
mono(policy.2.8.gconf-sharp) = 0.0.0.0
mono(policy.2.8.gconf-sharp-peditors) = 0.0.0.0
mono(policy.2.8.gnome-sharp) = 0.0.0.0
mono(policy.2.8.gnome-vfs-sharp) = 0.0.0.0

(http://koji.fedoraproject.org/koji/rpminfo?rpmID=647543)

Is this intentional?  Or gtkhtml now provided by a different package?
In the 2.16 gnome-sharp package gtkhtml was provided:

gnome-sharp = 2.16.1-3.fc10
libgnomesharpglue-2.so
libvtesharpglue-2.so
mono(art-sharp) = 2.16.0.0
mono(gconf-sharp) = 2.16.0.0
mono(gconf-sharp-peditors) = 2.16.0.0
mono(gconfsharp-schemagen) = 0.0.0.0
mono(gnome-sharp) = 2.16.0.0
mono(gnome-vfs-sharp) = 2.16.0.0
mono(gtkhtml-sharp) = 2.16.0.0
mono(policy.2.4.art-sharp) = 0.0.0.0
mono(policy.2.4.gconf-sharp) = 0.0.0.0
mono(policy.2.4.gconf-sharp-peditors) = 0.0.0.0
mono(policy.2.4.gnome-sharp) = 0.0.0.0
mono(policy.2.4.gnome-vfs-sharp) = 0.0.0.0
mono(policy.2.4.gtkhtml-sharp) = 0.0.0.0
mono(policy.2.4.rsvg-sharp) = 0.0.0.0
mono(policy.2.4.vte-sharp) = 0.0.0.0
mono(policy.2.6.art-sharp) = 0.0.0.0
mono(policy.2.6.gconf-sharp) = 0.0.0.0
mono(policy.2.6.gconf-sharp-peditors) = 0.0.0.0
mono(policy.2.6.gnome-sharp) = 0.0.0.0
mono(policy.2.6.gnome-vfs-sharp) = 0.0.0.0
mono(policy.2.6.gtkhtml-sharp) = 0.0.0.0
mono(policy.2.6.rsvg-sharp) = 0.0.0.0
mono(policy.2.6.vte-sharp) = 0.0.0.0
mono(policy.2.8.art-sharp) = 0.0.0.0
mono(policy.2.8.gconf-sharp) = 0.0.0.0
mono(policy.2.8.gconf-sharp-peditors) = 0.0.0.0
mono(policy.2.8.gnome-sharp) = 0.0.0.0
mono(policy.2.8.gnome-vfs-sharp) = 0.0.0.0
mono(policy.2.8.gtkhtml-sharp) = 0.0.0.0
mono(policy.2.8.rsvg-sharp) = 0.0.0.0
mono(policy.2.8.vte-sharp) = 0.0.0.0
mono(rsvg-sharp) = 2.16.0.0
mono(vte-sharp) = 2.16.0.0

(http://koji.fedoraproject.org/koji/rpminfo?rpmID=601424)

If gtkhtml-sharp isn't packaged we need to get it into review pronto.

Alex



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]