[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Heads-up: brand new RPM version about to hit rawhide



On Wed, 9 Jul 2008, Kevin Kofler wrote:

Panu Matilainen <pmatilai <at> redhat.com> writes:
Packagers:
8) Unnumbered Source: and Patch: are no longer accepted, you have to explicitly
write Source0: resp. Patch: (unless I misunderstood this commit:
http://devel.linux.duke.edu/gitweb/?p=rpm.git;a=commit;h=724b07bba5e802998b1b79b408c2401d2a238a3b ).

The commit message is a bit misleading, it's mostly about how rpmbuild deals with those internally. You're unlikely to notice anything at all, the change just makes some previously misleading errors more clear.

I hope packages which FTBFS (only) due to this and/or the patch fuzz issue
won't be considered for the FTFBS package elimination in a week, otherwise
we'll end up with half the distro removed! :-(

Package maintainers can set a less strict fuzz for their packages if they see fit - or fedora buildsys can override the rpm default .. that's pretty much up to FPC and the like to decide. 0 is just the upstream default.

	- Panu -


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]