[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Help wanted with Samba4 and OpenChange



On Wed, 2008-07-02 at 17:54 -0700, Jesse Barnes wrote:
> On Monday, June 30, 2008 7:01 pm Andrew Bartlett wrote:
> > I've recently been working on packaging Heimdal, Samba4 and OpenChange
> > for Fedora.
> >
> > https://bugzilla.redhat.com/show_bug.cgi?id=452212 (heimdal)
> > https://bugzilla.redhat.com/show_bug.cgi?id=453083 (Samba4)
> > https://bugzilla.redhat.com/show_bug.cgi?id=453395 (libmapi -
> > OpenChange)
> >
> > This will enable much better access to Microsoft Exchange servers from
> > clients such as kdepim, and hopefully Evolution (pending a
> > re-licensing).
> >
> > I've got a feature page for this here:
> >
> > https://fedoraproject.org/wiki/Features/OpenChange
> >
> > Now, the reason I'm posting here is that I would rather not do this
> > alone, and would love some co-maintainers of the packagers above, or at
> > least some help with the review and sponsorship, or advise on the best
> > way forward.
> >
> > Any assistance gratefully received,
> 
> Just pulled down the packages (including the alpha5 samba4 package) and 
> started building.  I haven't got to the kde libraries yet (that build will 
> probably take awhile) but on the packages above, I found the following:
> 
> heimdal:
>   - openssl-devel depends on krb5-devel, but heimdal-devel conflicts with
>     krb5-devel; should it provide it or do we need a virtual provides for
>     krb5?

I'm not sure what the best way to handle this interaction is.  This
build (due to the OpenSSL licence) avoids using OpenSSL as a build
depencency on Heimdal. 

I'm also not sure if the OpenSSL dependency on krb5 is useful anyway -
but we might be stuck with it.  (At one point it enabled an experimantal
krb5-in-SSL hack, which only OpenSSL supported). 

>   - heimdal seemed to be missing a file directive for the dir.gz info file
> samba4:
>   - everything seems fine here so far...
> libmapi:
>   - didn't list the popt requirement, so initially I built without it and the
>     packaging failed due to missing binaries (which required popt-devel)
>   - libmapi-devel should depend on libmapi-0.7... rather than
>     libmapi-libs-0.7...?

Thanks.  I'll look into it. 

> I've attached my spec file diffs in case you want to see (though now I see 
> you've already fixed the libmapi-libs problem I saw)...
> 
> Thanks for packaging this stuff, I really hope the MAPI Akonadi code works; 
> I'd *love* to ditch Outlook (it's the next best thing to escaping the 
> Exchange ghetto).

Now what I really need is a sponsor, or packager willing to take this
effort over...

Andrew Bartlett

-- 
Andrew Bartlett
http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org
Samba Developer, Red Hat Inc.

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]