[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20080715 changes



On Tue, Jul 15, 2008 at 7:05 AM, Harald Hoyer <harald redhat com> wrote:
> Tom London wrote:
>>
>> On Tue, Jul 15, 2008 at 3:37 AM, Rawhide <rawhide fedoraproject org>
>> wrote:
>>>
>>> rpm-4.5.90-0.git8426.7
>>> ----------------------
>>> * Mon Jul 14 18:00:00 2008 Panu Matilainen <pmatilai redhat com>
>>> - 4.5.90-0.git8426.7
>>> - fix mono dependency extraction (adjust for libmagic string change)
>>>
>>>
>>
>> After installing this, rpm seems very disfunctional:
>>
>> [root localhost packages]# rpm -q kernel
>> rpmdb: Program version 4.5 doesn't match environment version 0.128
>> error: db4 error(-30972) from dbenv->open: DB_VERSION_MISMATCH:
>> Database environment version mismatch
>> error: cannot open Packages index using db3 -  (-30972)
>> error: cannot open Packages database in /var/lib/rpm
>> rpmdb: Program version 4.5 doesn't match environment version 0.128
>> error: db4 error(-30972) from dbenv->open: DB_VERSION_MISMATCH:
>> Database environment version mismatch
>> error: cannot open Packages database in /var/lib/rpm
>> package kernel is not installed
>> [root localhost packages]#
>>
>> Same for "rpm --rebuilddb":
>>
>> [root localhost Downloads]# rpm --rebuilddb
>> rpmdb: Program version 4.5 doesn't match environment version 0.128
>> error: db4 error(-30972) from dbenv->open: DB_VERSION_MISMATCH:
>> Database environment version mismatch
>> error: cannot open Packages index using db3 -  (-30972)
>> [root localhost Downloads]#
>>
>> Didn't see anything strange during the update.
>>
>> Any thoughts on how to recover?
>>
>> tom
>
> # rm -f /var/lib/rpm/__*
>

Thanks, but I was a little quick on the trigger: rebooting seems to
have fixed this too.

Sorry,
   tom
-- 
Tom London


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]