[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Help debugging package build failure



+++ Rex Dieter [23/07/08 12:44 -0500]:
Rex Dieter wrote:

Rex Dieter wrote:

seth vidal wrote:

On Wed, 2008-07-23 at 11:27 -0400, Brenton Leanhardt wrote:
I'm fairly new to the koji build system and a package I've been
scratch building started failing today.  You can see the details here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=734161
...
/var/lib/mock/dist-f9-build-227923-40553/root/  install  'publican'
DEBUG util.py:250:  Error: Missing Dependency:
libakonadiprotocolinternals.so.0 is needed by package kdepimlibs

What I can't understand is what is pulling in kdepimlibs.  The spec
file only states:

BuildRequires:  publican
Requires:       httpd


I would guess it is coming from publican's dep on

yum deplist publican
  dependency: /usr/bin/xml2pot
   provider: kdesdk-utils.i386

See:
http://www.redhat.com/archives/fedora-devel-list/2008-July/msg01152.html

And as a followup, looks like the stuff in kdesdk-utils that once didn't
pull in any extra kde deps, now does (for some hopefully explainable and
revertable reason).

wee (love responding to myself), found the dep issue too, will be fixed in
kdesdk-utils-4.0.99-2

-- Rex

Thanks for tracking this down.  My package is building for dist-f9
again on koji. :)


--
fedora-devel-list mailing list
fedora-devel-list redhat com
https://www.redhat.com/mailman/listinfo/fedora-devel-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]