[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: A PackageKit browser plugin



On Thu, 2008-07-24 at 15:22 -0400, Owen Taylor wrote:
> On Thu, 2008-07-24 at 21:14 +0200, Dennis J. wrote:
> > Owen Taylor wrote:
> > > We've been working on a website for browsing (rating, commenting,
> > > etc) available applications for Fedora. As part of that we wanted
> > > to be able to install/run software from the website.
> > >
> > > I spent the last day hacking up a quick browser plugin:
> > 
> > Sounds like a great idea. I got the source and tried to compile it but I 
> > get this error:
> > 
> > src/contents.cpp: In member function 'void PkpContents::recheck()':
> > src/contents.cpp:119: error: cannot convert 'const char*' to 'PkFilterEnum' 
> > for argument '2' to 'gboolean pk_client_resolve(PkClient*, PkFilterEnum, 
> > const gchar*, GError**)'
> > make[2]: *** [packagekit_plugin_la-contents.lo] Error 1
> > make[2]: Leaving directory `/home/dennis/Downloads/source/packagekit-plugin'
> > make[1]: *** [all-recursive] Error 1
> > make[1]: Leaving directory `/home/dennis/Downloads/source/packagekit-plugin'
> > make: *** [all] Error 2
> > 
> > Does the plugin require a specific version of PackageKit?
> 
> I developed it against PackageKit-0.1.x, let me upgrade to 0.2.x from
> updates-testing and see if I can reproduce and fix the above. Richard
> keeps on telling me that 0.2.x is amazingly better anyways.

OK, should compile and work now if you repull.

- Owen



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]