[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: XULRunner and you



>> Packages using the stable API should have:
>>   Requires: gecko-libs >= 1.9
>>   BuildRequires: gecko-devel >= 1.9
>
> How would we go about requiring only 1.9* versions?  I would like the
> spec/package to break if/when xulrunner goes to the next version (obviously
> not in this release, but at some point in the future).
>
> For example, I can't do:
> Requires: gecko-libs < 2.0
>
> Because I'm not guaranteed that the next version will *be* 2.0 (it might be
> 1.10, for example).

It won't be 2. Firefox 3.1.x will ship with gecko 1.9.1.x where as FF
3.0 uses gecko 1.9.0.x. No idea how you'd specify that in rpm though.

Peter


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]