[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora i386 rawhide rebuild in mock status 2008-06-01



On Mon, Jun 02, 2008 at 01:48:11PM -0500, Jon Ciesla wrote:
> 
> > On Mon, Jun 02, 2008 at 12:01:02PM -0500, Jon Ciesla wrote:
> >>
> >> >
> >> >> astromenace-1.2-8.fc9 (build/make) limb
> >> >
> >> > Already foxed qof.  astromenace builds fine locally, but it looks like
> >> > this build failed because it was missing sdl-config, which is in
> >> > SDL-devel, an explicit BR, which mock pulled.  Running my own mock
> >> build
> >> > against devel now as a test. . .
> >>
> >> Finished.  Same error.  Builds just fine oon fc9 local.
> >
> > There's something wrong with $PATH for the build user inside the
> > buildroot when it fails for me.  I built it inside mock again, and see
> > the same failure.  However, if I edit the makefiles to point at
> > /usr/bin/sdl-config instead of simply sdl-config, it succeeds.
> 
> Could this be causing other problems/failures as well?

Turns out it's not quite that simple...   I just didn't let it run
long enough.

>From sitting inside the chroot, as the building user, I run:
$ make
Linking CXX executable AstroMenace
c++: `/usr/bin/sdl-config: No such file or directory
make[2]: *** [AstroMenace] Error 1
make[1]: *** [CMakeFiles/AstroMenace.dir/all] Error 2
make: *** [all] Error 2

but of course it's present.

CMakeFiles/AstroMenace.dir/link.txt
is our culprit.

If you look at that file, the line length is huge (>10k characters).
The `sdl-config --libs` is not getting evaluated in a shell, like the
code expects, it's being evaluated by /usr/bin/c++, which of course
fails.

Short story is, the invocations of sdl-config --libs   and sdl-config
--cflags should happen not quite as late as they are, but earlier,
where they can be evaluated and expanded by Makefile and not by c++.

-- 
Matt Domsch
Linux Technology Strategist, Dell Office of the CTO
linux.dell.com & www.dell.com/linux


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]