[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Backport F-9's grub to F-8


a couple of days ago I received a Dell Vostro 1400.

I dumped its windows vista Home edition,
and install an F8 x86_64 image on it (I just copied the partitions from another computer).
Then, I run grub-install /dev/sda using an F8 install DVD.

The problem is that when I tried to boot using the latest kernel 2.6.25-6-27.fc8,
and the newer grub, the boot hanged trying to load initrd.

However, I could boot normally using a 2.6.24 or 2.6.23 kernel.

Then, I downgraded grub to 0.97-19 and finally I could boot
to kernel 2.6.25.

I also noted that kernel 2.6.25 had a setup=0x300 and
the previous kernels 0x2c00 (the only difference I could see
loading initrd).

My question is: what has changed in grub, and
if I had run grub-install from the newer grub (0.97-33.1) the issue
would also be solved or could I get stuck for all kernels (not only for 2.6.25).


Paulo Roma Cavalcanti
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]