[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Backport F-9's grub to F-8

On Thu, Jun 26, 2008 at 11:09 AM, Eric Sandeen <sandeen redhat com> wrote:
Paulo Cavalcanti wrote:
> Hi,
> a couple of days ago I received a Dell Vostro 1400.
> I dumped its windows vista Home edition,
> and install an F8 x86_64 image on it (I just copied the partitions from
> another computer).
> Then, I run grub-install /dev/sda using an F8 install DVD.
> The problem is that when I tried to boot using the latest kernel
> 2.6.25-6-27.fc8,
> and the newer grub, the boot hanged trying to load initrd.
> However, I could boot normally using a 2.6.24 or 2.6.23 kernel.
> Then, I downgraded grub to 0.97-19 and finally I could boot
> to kernel 2.6.25. <http://2.6.25.>
> I also noted that kernel 2.6.25 had a setup=0x300 and
> the previous kernels 0x2c00 (the only difference I could see
> loading initrd).
> My question is: what has changed in grub, and
> if I had run grub-install from the newer grub (0.97-33.1) the issue
> would also be solved or could I get stuck for all kernels (not only for
> 2.6.25).

I'm not sure of the details of your problem, but just FWIW:


the latest grub is already headed for F8, for other reasons (handling
the larger ext3 inode size on F9 filesystems).

The problem is with this latest grub (0.97-33.1). 
It does not boot my kernel 2.6.25 on this laptop running F8 x86_64.
It boots kernel 2.6.24 and 2.6.23, though.

When I downgraded grub to 0.97-19, then kernel 2.6.25 booted just fine.

The only thing is that I did not install using the DVD.
I copied the partitions from another computer using partimage.
The partitions were previously created with gparted:

Filesystem    Type    Size  Used Avail Use% Mounted on
/dev/sda2     ext3     20G   13G  6.4G  66% /
/dev/sda1     ext3     99M   24M   71M  25% /boot
/dev/sda4     ext3    124G   12G  107G  10% /home

(/dev/sda3 is for swapping).

Of course, the new grub was working well on the computer the partitions
were copied from. To write the MBR on the laptop for the first time,
I used the grub-install from the original F8 x86_64 DVD.

I think the problem is an incompatibility between gparted 0.3.7
(from system-rescueCD 1.0.3) and the new grub.

Anyway, the laptop is working wonderfully well, including the webcam.
The only thing I am not able to make work is the digital microphone (but an
external analog mic does work fine).

Paulo Roma Cavalcanti
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]