[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FESCo Proposal for blocking older version of autoconf & automake



2008/5/5 Brian Pepple <bpepple fedoraproject org>:
> I received the following proposal from Karsten Hopp, which he would like
>  FESCo to make a decision on during this week's meeting (2008-05-08).
>  I'm forwarding it to the list, so that people can weigh-in on it.
>
>  ---
>
>  ´╗┐We are currently shipping an insane number of compatibility autofoo
>  packages which haven't seen any upstream maintenance for many years:
>
>  autoconf213-2.13-18.fc8.noarch.rpm   (9 years)
>  automake14-1.4p6-15.fc7.noarch.rpm   (6 years)
>  automake15-1.5-23.noarch.rpm         (7 years)
>  automake16-1.6.3-14.noarch.rpm       (6 years)
>  automake17-1.7.9-11.noarch.rpm       (4 1/2 years)
>
>  PROPOSAL: I'd like to keep just the following packages and would like to
>  have release engineering to block the older packages from Rawhide:
>  autoconf-2.61-10.fc9.noarch.rpm
>  automake-1.10.1-2.noarch.rpm
>
>  This is the complete list of rawhide packages requiring those ancient
>  autofoo packages, it is rather short and it should be doable to convert
>  those packages to current autofoo:
>
>  automake14 ax25-apps-0.0.6-2.fc9.src.rpm
>  automake14 gdk-pixbuf-0.22.0-36.fc9.src.rpm
>  automake14 glib-1.2.10-29.fc9.src.rpm
>  automake14 gtk+-1.2.10-61.fc9.src.rpm
>  automake14 sgml-common-0.6.3-23.fc9.src.rpm
>  automake14 WindowMaker-0.92.0-17.fc9.src.rpm
>
>  automake15 nss_db-2.2-40.fc9.src.rpm
>
>  automake16 kyum-0.7.5-11.fc9.src.rpm
>  automake16 qalculate-kde-0.9.6-5.fc9.src.rpm
>  automake16 sinjdoc-0.5-6.fc9.src.rpm
>
>  automake17 cegui-0.5.0b-7.fc9.src.rpm
>  automake17 ekg2-0.1.1-4.fc9.src.rpm
>  automake17 gtk2-2.12.9-5.fc9.src.rpm
>  automake17 nautilus-open-terminal-0.9-2.fc9.src.rpm
>
>  autoconf213 esc-1.0.1-9.fc9.src.rpm
>  autoconf213 glib-1.2.10-29.fc9.src.rpm
>  autoconf213 gtk+-1.2.10-61.fc9.src.rpm
>  autoconf213 pam_smb-1.1.7-8.2.2.src.rpm
>  autoconf213 xdvik-22.84.13-17.fc9.src.rpm
>
>  Maintainers are encouraged to switch to more recent releases of the
>  autoconf tools and/or work with upstream to get this done. They also
>  should make sure if it is really necessary to run p.e. automake at all
>  during the build process.
>
>  Later,
>  /B
>  --
>  Brian Pepple <bpepple fedoraproject org>
>
>  http://fedoraproject.org/wiki/BrianPepple
>  gpg --keyserver pgp.mit.edu --recv-keys 810CC15E
>  BD5E 6F9E 8688 E668 8F5B  CBDE 326A E936 810C C15E
>
> --
>  fedora-devel-list mailing list
>  fedora-devel-list redhat com
>  https://www.redhat.com/mailman/listinfo/fedora-devel-list
>

It would really be nice to encourage people to fix the cruft.
backwards compat packages (workarounds) usually just slow down the
process of getting that fixed properly. sure one can question the
priority of that change but i am also the opinion that it would be
something that could be cleaned up in a single iteration.

just my opinion,
Rudolf Kastl


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]