[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20081031 changes



On Sat, 1 Nov 2008, Kevin Kofler wrote:

Lillian Angel <langel <at> redhat.com> writes:
Correct. The -devel package now includes visualvm, which depends on
netbeans-platform8.

IMHO an optional tool which is not required to build Java programs has no
business being in java-1.6.0-openjdk-devel.

We can talk about moving this out to a separate package,

I think that makes a lot of sense.

and adding it as a "Suggests" for the java-1.6.0-openjdk-devel package.

Do we have all the infrastructure for soft dependencies in Fedora yet? I
don't think we do.

No we don't. Soft dependencies were supposed to go into rpm 4.6.0 but didn't make it afterall, as I wasn't happy with some details of the existing implementations and didn't get around to work them out in time.

	- Panu -


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]