[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Flash 10 in 64-bit F9: does it work?



--- On Sat, 11/8/08, Chris Adams  wrote:
> 
> It is working for me on F9/x86_64.  I didn't do
> anything special; I have
> the Adobe repo in my yum config and got
> flash-plugin-10.0.12.36-release
> with a yum update.
> -- 

I also got the same version of flash-plugin from the Adobe repo. It works but there is this infamous "grey rectangle bug" on 64 bit systems that drives me insane. I read very many discussions about this but there is no known solution (to me).

Basically when I go to a website that makes use of flash, sometimes the flash content is replaced with a grey box. Left- or right-clicking on the grey box doesn't do anything. The page needs to be reloaded (some times a large number of times) until it shows properly. Sometimes it turns to grey in the middle of a flash video that I'm watching (this is the most annoying case since some flash players don't have time-seeking feature, I have to watch everything over). The bug happens more often when I have multiple tabs/windows open that display websites with flash content.

The issue is reported on different linux systems (Ubuntu, Fedora...). Some say that it broke during a minor update in the 9.0.x series. I can't verify this because I couldn't find copies of old versions of flash plugins. 10.0.x series didn't fix the problem. 

Typically when the grey rectangle bug happens I get messages in the system log, such as

npviewer.bin[18365]: segfault at 13 ip 1493db7 sp ff9b3964 error 4 in libflashplayer.so[def000+951000]
npviewer.bin[13560]: segfault at 13 ip 1493db7 sp ffbb3364 error 4 in libflashplayer.so[def000+951000]
npviewer.bin[810]: segfault at 13 ip 1493db7 sp ffaaea64 error 4 in libflashplayer.so[def000+951000]
npviewer.bin[15403]: segfault at 13 ip 1493db7 sp ffdd0d84 error 4 in libflashplayer.so[def000+951000]
npviewer.bin[4703]: segfault at ff9d1e4c ip ff9d1e4c sp fffd45dc error 14

npviewer.bin segfaults are there in every single case. If someone knows of a solution or workaround, I'm all ears.

-Orcan


      


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]