[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: It's all ASPLODY!



On Mon, 2008-11-24 at 21:25 +0200, Ville Skyttä wrote:
> On Monday 24 November 2008, Ignacio Vazquez-Abrams wrote:
> 
> > Within the next few days Python 2.6 will be imported into Rawhide. This
> > means that EVERY single Python-based package in Rawhide will be broken,
> 
> Hmm, to clarify: really every one, or "just" every one that installs files 
> into versioned python dirs and/or depends on versioned python(abi)?
> 
> If a package installs some *.py, *.pyc, *.pyo somewhere else than in versioned 
> python dirs, and the source *.py is python 2.6 compatible, will the *.pyc and 
> *.pyo compiled with 2.5 break with 2.6?  For example, is it 
> necessary/beneficial to rebuild packages like rpmlint (all its python code is 
> either in /usr/bin or /usr/share/rpmlint)?

The Python API version (1013) has not changed between 2.5 and 2.6,
therefore the bytecode is compatible and .pyc and .pyo files in
version-independent locations do not need to be recompiled.

-- 
Ignacio Vazquez-Abrams <ivazqueznet gmail com>

PLEASE don't CC me; I'm already subscribed

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]