[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum upgrade from F-9 to F-10



On Thu, 27 Nov 2008, Michael Schwendt wrote:
In F-9 -> F-10 upgrade, I got the following error, which I worked
around by removing pidgin.  Could someone add that to YumUpgradeFaq
under F-10 specifics?

pidgin-2.5.2-2.fc9.i386 from installed has depsolving problems
   --> Missing Dependency: libedataserver-1.2.so.9 is needed by package pidgin-2.5.2-2.fc9.i386 (installed)
Error: Missing Dependency: libedataserver-1.2.so.9 is needed by package pidgin-2.5.2-2.fc9.i386 (installed)


It's a typical upgrade path issue. F-10 comes with 2.5.2-1.fc10 which is
seen as "older than" 2.5.2-2.fc9 because of the higher "2" release in the F-9 pkg.
You would need the newer piding from updates-testing to resolve this.

Yes, I realized this later. This always seems to come up at upgrade -- if you previously used updates-testing, its yum repo config gets replaced, and you have to remember to re-enable it.

This "remember to re-enable updates-testing after installing new fedora-release packages" is something that should also be mentioned in the FAQ.

Or even better, we should figure out how to preserve the previous configuration in this respect.

--
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]