[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rawhide report: 20081004 changes



[...]

Trying to do a quick audit/triage of the remaining broken deps (some
of which have lingered for >2 months!  (I will also repeat my request
to move the "broken deps" section to the top of the rawhide report so
that it gets more regular attention from all developers).

Alex

> Broken deps for i386
> ----------------------------------------------------------
>	asterisk-mobile-1.6.0-0.21.beta9.fc10.i386 requires libbluetooth.so.2

 Failed a rebuild:
 
 https://koji.fedoraproject.org/koji/taskinfo?taskID=820346
 
 Opened a bug: http://bugzilla.redhat.com/465661
 
 Looks like official 1.6.0 has been released as well...

>	beagle-evolution-0.3.8-6.fc10.i386 requires mono(evolution-sharp) = 0:3.0.0.0

 Just recently rebuilt.

>	gtkmozembedmm-1.4.2.cvs20060817-21.fc10.i386 requires gecko-libs = 0:1.9.0.1

 This appears to be orphaned in CVS (dead.package) but it hasn't been
 properly blocked by rel-eng.  Owner according to:
 
 https://admin.fedoraproject.org/pkgdb/packages/name/gtkmozembedmm
 
 is hguemar.  Was this intentional?  Is gtkmozembedmm supposed to be
 removed from rawhide?  Has it been superceded by other packages?
 Can't find any bug about this.

>	lvm2-cluster-2.02.39-3.fc10.i386 requires libcman.so.2
>	lvm2-cluster-2.02.39-3.fc10.i386 requires libdlm.so.2

 Last attempted rebuild failed:

 https://koji.fedoraproject.org/koji/buildinfo?buildID=64052

 Appears to be a patch on: http://bugzilla.redhat.com/465249 which may
 fix it, but I can't apply it because of the # 1!* ACLs. Owner: please
 consider removing ACLs.

>	perl-DBIx-Class-0.08010-7.fc10.noarch requires perl(Actor)
>	perl-DBIx-Class-0.08010-7.fc10.noarch requires perl(Film)
>	perl-DBIx-Class-0.08010-7.fc10.noarch requires perl(Director)

 Recently rebuilt correctly, but may provides some bogus provides?
 Opened bug: http://bugzilla.redhat.com/465663

>	pyclutter-0.6.2-2.fc9.i386 requires libclutter-glx-0.6.so.0
>	pyclutter-cairo-0.6.2-2.fc9.i386 requires libclutter-cairo-0.6.so.0
>	pyclutter-cairo-0.6.2-2.fc9.i386 requires libclutter-glx-0.6.so.0
>	pyclutter-gst-0.6.2-2.fc9.i386 requires libclutter-gst-0.6.so.0
>	pyclutter-gst-0.6.2-2.fc9.i386 requires libclutter-glx-0.6.so.0
>	pyclutter-gtk-0.6.2-2.fc9.i386 requires libclutter-glx-0.6.so.0
>	pyclutter-gtk-0.6.2-2.fc9.i386 requires libclutter-gtk-0.6.so.0

 Fails to rebuild:

 https://koji.fedoraproject.org/koji/buildinfo?buildID=62714

 Also brought up in earlier thread on f-d-l:

 http://www.redhat.com/archives/fedora-devel-list/2008-October/msg00020.html

 but no response.  There is an open FTBFS bug: http://bugzilla.redhat.com/465096

>	ruby-rpm-1.2.3-4.fc9.i386 requires librpmdb-4.4.so
>	ruby-rpm-1.2.3-4.fc9.i386 requires librpm-4.4.so
>	ruby-rpm-1.2.3-4.fc9.i386 requires librpmio-4.4.so
>	ruby-rpm-1.2.3-4.fc9.i386 requires librpmbuild-4.4.so

 This won't build until it is ported to use RPM 4.6.  Is this
 underway?  Looking at upstream
 http://rubyforge.org/projects/ruby-rpm/ there hasn't been a new
 release since May 2007, so I'm guessing the project may be dead.
 Could the maintainer have a look at this, or otherwise block it from
 rawhide if it can't be ported.  There is an existing FTBFS bug:
 http://bugzilla.redhat.com/465103


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]