[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Cannot recompile x86_64 kernel on installed F9 i686



I tried to recompile the x86_64 version of the F10beta kernel on my F9
i686. And this is the error message I got

------
+ perl -p -i -e 's/^EXTRAVERSION.*/EXTRAVERSION =
-0.352.rc7.git1.fc10.x86_64/' Makefile
+ make -s mrproper
+ cp configs/kernel-2.6.27-x86_64.config .config
++ head -1 .config
++ cut -b 3-
+ Arch=x86_64
+ echo USING ARCH=x86_64
USING ARCH=x86_64
+ make -s ARCH=x86_64 nonint_oldconfig
+ make -s ARCH=x86_64 V=1 -j3 bzImage
#
# configuration written to .config
#
  SYMLINK include/asm -> include/asm-x86
scripts/mod/empty.c:1: error: code model 'kernel' not supported in the
32 bit mode
scripts/mod/empty.c:1: sorry, unimplemented: 64-bit mode not compiled in
make[2]: *** [scripts/mod/empty.o] Error 1
make[1]: *** [scripts/mod] Error 2
make[1]: *** Waiting for unfinished jobs....
make: *** [scripts] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.7836 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.7836 (%build)
---------

Recompiling the i686 kernel works fine but not the x86_64. Tried also
the lastes kernel in koji and got the same error. How to recompile it?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]