[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Heads-up: libdap and libnc-dap updates



Hello,

I would like to update libnc-dap to the latest version, and for that it
requires a more recent libdap, which is both ABI and API incompatible.
libnc-dap should be ABI compatible.

My proposal, to avoid having to rebuild everything at once and provide
for an easy upgrade path is to provide a compat package:
http://www.environnement.ens.fr/perso/dumas/fc-srpms/libdap3710-3.7.10-1.fc10.src.rpm
http://www.environnement.ens.fr/perso/dumas/fc-srpms/libdap3710.spec

Does it looks good? 

I don't want to do devel compat package, I don't think it is needed,
and this compat package should be removed in F12 or so.

I will do the submission if no one raises issues.

After that, it would be nice if application linked against libnc-dap
would be rebuilt, since libnc-dap now uses pckgonfig and previously it 
was possible that it added spurious link on unneeded libraries, leading
to unneeded dependencies.

I cannot provide a list of packages dependent on libdap-devel and
libc-dap-devel since repoquery crashes here.

--
Pat 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]