[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

python-2.6 and python-3.x



I had the fortune to attend pycon this past week and went to a talk
about python-2.6 compatibility with python-3.

http://us.pycon.org/2009/conference/schedule/event/74/

The slides from that are available and largely self-explanatory.  They
list tricks for getting python code that runs on both py2.6 and py3.x.

However, one of the things that isn't obvious is what's missing from the
equation to make the idea of porting one library at a time work.  The
ideas in the slides hinge upon writing code that runs on python3.x and
then making that backwards compatible with python-2.6's py3
compatibility.  In Fedora, we're going to have the problem of taking
code and trying to port it to python-2.6's py3 compatibility layer and
then fixing it to run on py3k if necessary.  This is much harder as
python-2.6 will accept most python-2.5 and less code so we won't know
when we're using idioms that will not work in python-3.x.

Another thing that's missing is a 2to3 like tool that targets 2.6+compat
instead of python3.  However, this one might be possible if we ask.

A side note is that the Core devs apparently talked about naming the
interpreter binary for python /usr/bin/python3 at the language summit.
If they do this, /usr/bin/python will always mean python2 and
/usr/bin/python3 will be for python-3.x.  Not sure if that influences us
or not.

I don't have a solution for this yet.  Just throwing this out there as
something we need to consider as we start to port code to python-2.6
+py3 compat.

-Toshio

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]