[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: qt 4.5



On Wed, Apr 15, 2009 at 9:15 PM, Adam Williamson <awilliam redhat com> wrote:
> On Wed, 2009-04-15 at 14:03 +0200, Kevin Kofler wrote:
>> Jaroslav Reznik wrote:
>> > It should obsolete the first one, shouldn't it?
>>
>> Does obsoletion also work if the EVR is the same? I'd expect it to only work
>> if the EVR is newer.
>
> No, it works like Requires or Provides or anything else. If you don't
> version the obsolete it will obsolete any package of this name. So
> foobar-1.0-1fc11 with a line:
>
> Obsoletes: oldfoo
>
> will obsolete oldfoo-2.0-1fc11, or oldfoo-1.0-15fc11, or oldfoo-
> *anything*.
>
> That's why obsoletes ought to be versioned (something like Obsoletes:
> oldfoo < 1.0-1), so that they don't come back to bite you in future -
> for instance, if the name changes back.

They are talking about an update obsoletes and older one in bodhi.
Not package obsoletes an other package.


Well deleting the old update and adding it to the new group should work.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]