[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Trouble formatting flash disk


I have a pendrive (flash memory) which lists in /proc/bus/usb/devices as:

T:  Bus=01 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#=  4 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1043 ProdID=8012 Rev= 1.00
S:  Manufacturer=Generic
S:  Product=Flash Disk
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0m

Partition table is as follows:

Disk /dev/sdd: 67.1 GB, 67108864512 bytes
64 heads, 32 sectors/track, 64000 cylinders
Units = cilindros of 2048 * 512 = 1048576 bytes
Disk identifier: 0x4a26a3ed

Dispositivo Boot      Start         End      Blocks   Id  System
/dev/sdd1               1       64000    65535984   83  Linux

And I've tried to format it as ext2 (so I can backup my home directory). It happens that no matter what I do (and I've tried almost everything) it formats but no matter what I do when I record a large file (2GBytes) it generates file system inconsistencies.

First I thought that perhaps the device was defective. But when I try to write and read it, everything seems to be OK. It even passes badblock -w ...

Any suggestions on what may be wrong?

Best regards,


Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]