[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ATTN: Changes to OCaml dependency generator for RPM 4.8 in Rawhide



On Wed, Dec 16, 2009 at 06:34:09PM +0200, Panu Matilainen wrote:
> With the new rpm, all you need to have in the spec for this case is:
>
> %global __ocaml_requires_opts -i Asttypes -i Parsetree
>
> These will get passed to __ocaml_requires automatically when it runs,  
> and similarly to pass options to provides script, define  
> __ocaml_provides_opts macro to your liking.

OK, I didn't see that, but that's even better.

Rich.

-- 
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
libguestfs lets you edit virtual machines.  Supports shell scripting,
bindings from many languages.  http://et.redhat.com/~rjones/libguestfs/
See what it can do: http://et.redhat.com/~rjones/libguestfs/recipes.html


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]