[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Question about a lib requires



Le Fri, 18 Dec 2009 18:04:27 +0000,
Adam Williamson <awilliam redhat com> a écrit :

> On Fri, 2009-12-18 at 19:11 +0200, Jussi Lehtola wrote:
> 
> > > > Is there a way to include these requires properly ? (like adding
> > > > directly /usr/bin/jpegtran and /usr/bin/tiffinfo in Requires).
> > > Yes.
> > > 
> > > Requires: /usr/bin/jpegtran
> > > Requires: /usr/bin/tiffinfo
> > > 
> > > Does it really just need the binaries and not the libs, just that
> > > rpm would auto-Require the libjpeg and libtiff RPMs?
> > 
> > And if it actually needs the binaries, then you can just put in  
> >  Requires: libjpeg, libtiff
> > and safely ignore the rpmlint warning. AFAIK resolving file
> > dependencies is a lot slower than resolving explicit dependencies.
> 
> +1: just requiring the library packages and ignoring the rpmlint
> warning seems correct here, to me. You are smarter than rpmlint,
> after all. rpmlint is just considering the case where you're adding a
> library dependency, not realizing it will be automatically generated.
> It is not considering the case where the library package includes a
> binary that you need to depend on.

I think I'll use :
Requires: /usr/bin/jpegtran
Requires: /usr/bin/tiffinfo

so if one day these files are put in a different package than the lib,
I won't be "surprised"

Fabien Nicoleau


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]