[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Mono.Cecil & monodevelop-debugger-mdb



Hi,

MD-debugger-mdb is currently broken for rawhide. I've tried many ways to
get it to build and have finally asked for help from the the md mailing
list. The big problem is that we're using a system wide Mono.Cecil
rather than individual packages having their own version of Mono.Cecil.

Here's the conversation followed by a request from me...

8-->
On Wed, Dec 23, 2009 at 4:14 PM, Paul <paul all-the-johnsons co uk>
wrote:
> I've got MD-2.2 installed from Fedora rawhide and am trying to build
the
> MD debugger plugin. Problem is that it's looking for Mono.Cecil in the
> MD addins.
>
> With Fedora, we use a system wide Mono.Cecil instead of having a pile
of
> them around the place.

We use a local copy of Cecil because Cecil API is (was?) not
guaranteed to be stable and therefor the library is *supposed* to be
bundled with apps. This also allows us to rely on the exact behaviour
of the version we ship. By upgrading MD's Cecil to one it has not been
tested with, Fedora is potentially exposing their users to bugs that
we will be unable to reproduce and fix.

See http://www.mono-project.com/Cecil#Using_Cecil
<--8

Given this, should we change the approach we currently have for using
the system wide Mono.Cecil and allow the likes of MD to ship with it's
own version of Mono.Cecil?

Mono.Cecil is not added into GAC so having different versions of
Mono.Cecil for different applications should not cause conflicts.
"Should" is being used in it's lightest sense!

TTFN

Paul

P.S. Going off until Boxing Day now, so Merry Christmas to you all!
-- 
Sie können mich aufreizen und wirklich heiß machen!

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]