[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Why is X and IPv6 required for autoreconf?



Hi,

I ran across something weird over the holidays. I wanted to do some work on 
the audit package and put its srpm on a rawhide machine. The changes I made 
required regenerating the configure script by running autoreconf. My rawhide 
machine is a laptop which I have hardened since I travel with it. One of the 
precautions was disabling IPv6. When I rebuild my package, it dies like this:

make  all-recursive
make[1]: Entering directory `/home/sgrubb/working/BUILD/audit-1.7.11'
Making all in lib
make[2]: Entering directory `/home/sgrubb/working/BUILD/audit-1.7.11/lib'
gcc -DHAVE_CONFIG_H -I. -I.. -I. -I.. -I../auparse   -fPIC -DPIC -D_GNU_SOURCE '-DTABLE_H="actiontab.h"' -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -MT 
gen_actiontabs_h-gen_tables.o -MD -MP -MF .deps/gen_actiontabs_h-gen_tables.Tpo -c -o 
gen_actiontabs_h-gen_tables.o `test -f 'gen_tables.c' || 
echo './'`gen_tables.c
mv -f .deps/gen_actiontabs_h-gen_tables.Tpo .deps/gen_actiontabs_h-gen_tables.Po
/bin/sh ../libtool --tag=CC   --mode=link 
gcc -fPIC -DPIC -D_GNU_SOURCE '-DTABLE_H="actiontab.h"' -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic   -o 
gen_actiontabs_h gen_actiontabs_h-gen_tables.o  
../libtool: line 821: X--tag=CC: command not found
../libtool: line 854: libtool: ignoring unknown tag : command not found
../libtool: line 821: X--mode=link: command not found
../libtool: line 988: *** Warning: inferring the mode of operation is 
deprecated.: command not found
../libtool: line 989: *** Future versions of Libtool will require --mode=MODE 
be specified.: command not found
../libtool: line 2226: X-fPIC: command not found
../libtool: line 2226: X-DPIC: command not found
../libtool: line 2226: X-D_GNU_SOURCE: command not found
../libtool: line 2226: X-DTABLE_H="actiontab.h": command not found
../libtool: line 2226: X-O2: command not found
../libtool: line 2226: X-g: command not found
../libtool: line 2226: X-pipe: command not found
../libtool: line 2226: X-Wall: command not found
../libtool: line 2226: X-Wp,-D_FORTIFY_SOURCE=2: command not found
../libtool: line 2226: X-fexceptions: command not found
../libtool: line 2226: X-fstack-protector: command not found
../libtool: line 2226: X--param=ssp-buffer-size=4: command not found
../libtool: line 2061: X-m64: command not found
../libtool: line 2061: X-mtune=generic: command not found
../libtool: line 2395: Xgen_actiontabs_h: command not found

Fatal server error:
Server is already active for display 0
	If this server is no longer running, remove /tmp/.X0-lock
	and start again.

../libtool: line 2407: Xgen_actiontabs_h: command not found
../libtool: line 2415: mkdir /.libs: No such file or directory
mkdir: cannot create directory `/.libs': Permission denied
make[2]: *** [gen_actiontabs_h] Error 1


Next I delete the lock like it asks and it now dies like this:


../libtool: line 2226: X-Wp,-D_FORTIFY_SOURCE=2: command not found
../libtool: line 2226: X-fexceptions: command not found
../libtool: line 2226: X-fstack-protector: command not found
../libtool: line 2226: X--param=ssp-buffer-size=4: command not found
../libtool: line 2061: X-m64: command not found
../libtool: line 2061: X-mtune=generic: command not found
../libtool: line 2395: Xgen_actiontabs_h: command not found
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/livestrong:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already 
running
../libtool: line 2407: Xgen_actiontabs_h: command not found
../libtool: line 2415: mkdir /.libs: No such file or directory
mkdir: cannot create directory `/.libs': Permission denied


Then I decide, this should not require X at all and reboot to run level 3. 
When I compile now, it tries to start the X server when it gets to this 
point - of course it fails.

-Steve


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]