[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

emacs fan help with packaging .el



Hello there,

I have never used emacs before.

I'm packaging a few items which includes *.el for emacs.

after following https://fedoraproject.org/wiki/Packaging/Emacs,
I've prepared the spec file:
http://chitlesh.fedorapeople.org/RPMS/dinotrace.spec
http://chitlesh.fedorapeople.org/RPMS/dinotrace-9.3f-1.fc10.src.rpm

Nevertheless, the  emacs-dinotrace requires dinotrace-doc for
installing. But dinotrace.spec doesn't ship dinotrace-doc. I don't
know how this dependency is being pulled up.

[root cgoorah ~]# rpm -ivh
/home/chitlesh/rpmbuild/RPMS/i386/emacs-dinotrace-9.3f-1.fc10.i386.rpm
error: Failed dependencies:
        dinotrace-doc = 9.3f-1.fc10 is needed by
emacs-dinotrace-9.3f-1.fc10.i386

Can you also verify how I'm getting the *.el installed please ? I'll
use that as a template for my other packages.

thanks,
Chitlesh


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]