[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Atlas and lapack provide the same library..compiled differently... is that a problem?



2009/1/5 Jeff Spaleta <jspaleta gmail com>:
> On Mon, Jan 5, 2009 at 3:26 AM, Michael Schwendt <mschwendt gmail com> wrote:
>> This has been reported before in bugzilla, but according to the package
>> maintainer the libraries are compatible.
>
> And yet, I have a user reporting missing symbols errors when the
> linker attempts to use the lapack package libraries instead of the
> atlas libraries. If they were compatible before, something has
> changed.

Yes - the problem is that that Atlas implemented versions of lapack
symbols get prefixed with clapack_ so these two liblapack libraries
are not ABI compatible.

This is an ugly situation - I think the Atlas liblapack should be
renamed to something else, personally.

However, to fix your scipy problem, wouldn't a Requires: atlas "fix"
the issue? (And associated BuildRequires, I guess). That's an obscene
hack tho :).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]