[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Python, distutils, rpmbuild, issues



Jesse Keating wrote:
No, this won't work.  5.0.0_rc2 is in fact rpm newer than 5.0.0.
Is there some way to force rpm to recognize 5.0.0 as newer than 5.0.0_rc2? How else are you supposed to handle the release candidate packaging?

As to your other problem, I haven't even attempted it as the distutils
generated spec file isn't acceptable to Fedora packaging standards,
Why is this? I've built RPMS using bdist_rpm and they work just fine. You can configure things in setup.cfg. Of course I had to force an ignore of the "Installed but not packaged files" error which is not a permanent solution to the problem. I would prefer to use 'bdist_rpm' and not develop a whole new way of building python packages when distutils can already do this. If something cannot be configured then I think distutils should be enhanced.

Regards,
Gerry


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]