[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: xzgv in Fedora broken?



Paulo Cavalcanti wrote:


On Tue, Jan 6, 2009 at 1:23 PM, Rahul Sundaram <sundaram fedoraproject org <mailto:sundaram fedoraproject org>> wrote:

    Hans de Goede wrote:

        Note I'm looking in to fixing the xzgv thumbnails issue. Why? To
        show that actually reporting problems helps I guess.


    Thanks Hans. It is amazing, people who knew about the issue would be
    not reporting the bug but be willing to build conflicting packages
    in another repository.



Please, Rahul

xzgv does not impact anything.

True, never the less I've fixed it: a gtk callback functions return value was declared void while it should be gboolean and it should return TRUE, that this worked with gcc3 is just plain luck.

A patch is forth coming, I'm still looking into some of the thumbnails being wrong for images whose width is not a multiple of 4. Its a pitch/stride != width issue, and I've already located it, but it needs some surgery to fix cleanly.

Once more, here is the fixed memtest86+ for F10. It works just fine (for me) even on new Intel G45.

http://people.atrpms.net/~pcavalcanti/srpms/memtest86+-2.11-3.fc10.src.rpm


Yes this is a more important issue, thanks for bringing it to our attention. First of all it would help if you could post a patch with your prepared fix, that is less cumbersome to take a quick peek then an srpm. This is important because, for example yesterday I clicked at the bug report you linked and when only seeing srpm's went on with other stuff. If there would have been a patch attached I would have clicked it, and if it is cleanly I would have tried to get it in to Fedora asap. But the srpm was just too big of a hurdle (given that memtest is not a package I maintain, nor is xzgv btw).

Thanks & Regards,

Hans


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]