[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: xzgv in Fedora broken?





On Wed, Jan 7, 2009 at 12:00 PM, Paulo Cavalcanti <promac gmail com> wrote:


On Wed, Jan 7, 2009 at 10:32 AM, Hans de Goede <j w r degoede hhs nl> wrote:
Paulo Cavalcanti wrote:



On Tue, Jan 6, 2009 at 1:23 PM, Rahul Sundaram <sundaram fedoraproject org <mailto:sundaram fedoraproject org>> wrote:

   Hans de Goede wrote:

       Note I'm looking in to fixing the xzgv thumbnails issue. Why? To
       show that actually reporting problems helps I guess.


   Thanks Hans. It is amazing, people who knew about the issue would be
   not reporting the bug but be willing to build conflicting packages
   in another repository.



Please, Rahul

xzgv does not impact anything.

True, never the less I've fixed it: a gtk callback functions return value was declared void while it should be gboolean and it should return TRUE, that this worked with gcc3 is just plain luck.

A patch is forth coming, I'm still looking into some of the thumbnails being wrong for images whose width is not a multiple of 4. Its a pitch/stride != width issue, and I've already located it, but it needs some surgery to fix cleanly.

You are good. I thought it would take longer.

 


Once more, here is the fixed memtest86+ for F10. It works just fine (for me) even on new Intel G45.

http://people.atrpms.net/~pcavalcanti/srpms/memtest86+-2.11-3.fc10.src.rpm


Yes this is a more important issue, thanks for bringing it to our attention. First of all it would help if you could post a patch with your prepared fix, that is less cumbersome to take a quick peek then an srpm. This is important because, for example yesterday I clicked at the bug report you linked and when only seeing srpm's went on with other stuff. If there would have been a patch attached I would have clicked it, and if it is cleanly I would have tried to get it in to Fedora asap. But the srpm was just too big of a hurdle (given that memtest is not a package I maintain, nor is xzgv btw).


Here are the differences using Fedora original spec (although the .src.rpm is slightly different):

http://people.atrpms.net/~pcavalcanti/patches/spec.patch

http://people.atrpms.net/~pcavalcanti/patches/setup.patch

The fix is simple, and the grub entry is going to be this way:


title Memtest86+ v2.11
        kernel --type=netbsd /memtest86+-2.11


It has been working fine for me, with a lot of different computers,
for about two years.




I would like to add that I always have a /boot partition.

I never tested it with a different configuration (without /boot, for instance) or
using lvm. Maybe nothing does change, but this is why I always avoided to
to get involved, because I do not have how to test all of the configurations.


--
Paulo Roma Cavalcanti
LCG - UFRJ

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]