[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems with X font handling



Pete Zaitcev <zaitcev redhat com> wrote:
> On Mon, 12 Jan 2009 17:17:46 -0300, "Horst H. von Brand" <vonbrand inf utfsm cl> wrote:
> 
> > Lots of X programs (xemacs, xlogo, xfig) complain of missing fonts (and end
> > up using some cheesy default font). I reported this originally against
> > xemacs (at 478999), and now changed it to xorg-x11 as I believe this is a
> > better match. xfontsel has only 4 fonts to exhibit now in all. This is

> Assuming you already verified that fonts are actually installed

$ yum list installed "xorg-x11-fonts-*"
Loaded plugins: fastestmirror, refresh-packagekit
Installed Packages
xorg-x11-fonts-100dpi.noarch               7.2-6.fc9
xorg-x11-fonts-75dpi.noarch                7.2-6.fc9
xorg-x11-fonts-ISO8859-1-100dpi.noarch     7.2-6.fc9
xorg-x11-fonts-ISO8859-1-75dpi.noarch      7.2-6.fc9
xorg-x11-fonts-Type1.noarch                7.2-6.fc9
xorg-x11-fonts-misc.noarch                 7.2-6.fc9

> please run the following test for me:
> 
> 1. Log in
> 2. Open gnome-terminal
> 3. run xemacs and verify that it fails like you described

Fails.

> 4. su, "service xfs restart"

xfs: unrecognized service

(No, I did not do anything here except religiously updating X and axing
xorg.conf when told so. And particularly, I did nothing specially X-related
during the great font handling overhaul.)

There is no xorg-x11-xfs installed here (and that used to work fine). On
another machine (a bit carelessly handled, sorry) what I have is
xorg-x11-xfs-1.0.5-3.fc10.x86_64, installed in July (legacy
leftover?). There I get:

  Warning: Cannot convert string "-*-helvetica-bold-r-*-*-*-120-*-*-*-*-*-*" to type FontStruct
  Warning: Missing charsets in String to FontSet conversion

> 5. run xemacs again

On the other machine with xfs I restarted that one, and starting xemacs
again gives me the message stated. There I have

xorg-x11-fonts-100dpi.noarch             7.2-6.fc9
xorg-x11-fonts-75dpi.noarch              7.2-6.fc9
xorg-x11-fonts-ISO8859-1-100dpi.noarch   7.2-6.fc9
xorg-x11-fonts-ISO8859-1-75dpi.noarch    7.2-6.fc9
xorg-x11-fonts-Type1.noarch              7.2-6.fc9
xorg-x11-fonts-misc.noarch               7.2-6.fc9
xorg-x11-fonts-truetype.noarch           7.2-4.fc9

> If it still fails on step 5, it's not bug 430416. If it starts working,
> then the problem is that we fixed it in libraries somewhere (with
> X server remaining broken), and perhaps your apps use old libraries.
> 
> Please let me know how it goes.
-- 
Dr. Horst H. von Brand                   User #22616 counter.li.org
Departamento de Informatica                    Fono: +56 32 2654431
Universidad Tecnica Federico Santa Maria             +56 32 2654239
Casilla 110-V, Valparaiso, Chile 2340000       Fax:  +56 32 2797513


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]