[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Package doesn't build in Koji, but can be built locally using mock!





Mamoru Tasaka <mtasaka ioa s u-tokyo ac jp> wrote on 01/16/2009 07:13:18 AM:

Mamoru Tasaka wrote, at 01/16/2009 03:26 AM +9:00:
Hedayat Vatankhah wrote, at 01/16/2009 03:05 AM +9:00:
Hi all,
I'm the maintainer of rcssserver3d package. The package has been built in rawhide successfully, but recently I just removed a font file from the package and tried to build the package again in koji, but it failed. The build log says that it is unable to find /usr/lib64/libIL.so, but it should be able to find it. I didn't change anything related to it. Also, I tried to build the package using mock (make mockbuild) and the package was able to find the library! I wonder what's the problem?!

koji link: http://koji.fedoraproject.org/koji/taskinfo?taskID=1055760

Thanks,
Hedayat

At least DevIL-1.7.5-1.fc11 seems broken as now ldd reports that libIL.so.1 contains undefined non-weak symbols. config.log shows:

-------------------------------------------------------------------
configure:22286: g++ -o conftest -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic    -lIL conftest.cpp  >&5
/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../lib64/libIL.so: undefined reference to `ilLoadVtf'
/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../lib64/libIL.so: undefined reference to `ilLoadVtfF'
/usr/lib/gcc/x86_64-redhat-linux/4.3.2/../../../../lib64/libIL.so: undefined reference to `ilLoadVtfL'
collect2: ld returned 1 exit status
configure:22293: $? = 1
configure: failed program was:
| #include <IL/il.h>
| #include <stdarg.h> /* _vsnprintf may be undefined (and it is needed by libIL) */
| extern "C" int _vsnprintf(char *str, size_t size, const char *format, va_list ap) { return 0;}
| int main(int argc, char **argv) { ilInit(); return 0; }
configure:22360: WARNING: The DevIL library (libIL.a or libIL.so) cannot be found.
-------------------------------------------------------------------

I guess this needs bug report against DevIL.

... and filed:
https://bugzilla.redhat.com/show_bug.cgi?id=480269

Mamoru

Thanks. I found that my local mock have used DevIL-1.6.8 from rawhide and so it worked with no problem.

Hedayat

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]