[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem with autotools



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



Jerry James wrote:
> On Sat, Jan 17, 2009 at 10:34 PM, Randy Berry <randyn3lrx gmail com> wrote:
>> I am trying to build a package and the source relies on autotools. I'm
>> getting an error during the build install stage that I don't
>> understand.
>> Below are the pastes to the errors I am getting when trying to run
>> 'rpmbuild -bi'
>>
>> rpmbuild full output: http://fpaste.org/paste/1661
>> spec file: http://fpaste.org/paste/1662
>> rpmbuild output (short version): http://fpaste.org/paste/1664
>>
>> Anyone familiar with this error that knows how to fix it?
>> I'm pretty sure a patch is needed and I know how to make and apply a
>> patch I just don't know where to begin at making the patch.
>>
>> Thanks,
> 
> Randy,
> 
> It looks like you just need to copy or link
> /usr/share/automake-<version #>/mkinstalldirs into the top-level
> source directory.  If you do this at build time (instead of making a
> patch), make sure you BuildRequires the appropriate version of
> automake.
> 
> Regards,
	HI Jerry,
I got it to build using the autogen.sh and it works just fine on
rpmbuild but when I try to build it on mock it errors out on 'You must
have 'glib' installed". I added glib to the BR and still the same. I
even tried adding it to the requires as well and it still failed. Even
with glib in both requires and buildrequires it still fails. I'm stuck
there now. I looked for specific version requests but could not find any.
Thanks,
	Randy
- --
Randall J. Berry
IRC: Dp67, N3LRX
Email: <randyn3lrx gmail com> gpg key: 0x8479625D
Fingerprint: 40B4 2E18 DE47 29DD 9E13 BFD6 D558 96D3 8479 625D

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iEYEARECAAYFAklzzVgACgkQ1ViW04R5Yl1loACfe1u3vbmiWZWsw1jcUM36sWSO
F7IAn1gBMDhHoQPvcgf/52+rPxqDwPfM
=m630
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]